summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTimothy Redaelli2015-07-14 15:22:27 +0200
committerTimothy Redaelli2015-07-14 15:22:27 +0200
commit6c1a3075ca38e817b081eb8be89910fe49f925ae (patch)
treed9dc7f5aa969625c4afcc7b9e0a57e81500d6821 /PKGBUILD
downloadaur-vim-detectindent-git.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..baeedb32e38c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
+pkgname=vim-detectindent-git
+pkgver=0.r20.c6f6e7b
+pkgrel=1
+pkgdesc="Vim script for automatically detecting indent setting"
+arch=('any')
+url="http://github.com/ciaranm/detectindent"
+license=('custom:vim')
+groups=('vim-plugins')
+conflicts=('vim-detectindent')
+depends=('vim')
+makedepends=('git')
+source=('detectindent::git+https://github.com/ciaranm/detectindent.git'
+ license.txt)
+md5sums=('SKIP'
+ 'b779e18be6ed77facc770691c967b8f8')
+
+pkgver() {
+ cd "detectindent"
+ printf "0.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "detectindent"
+ local _installpath="${pkgdir}/usr/share/vim/vimfiles"
+
+ install -d "$_installpath"
+ cp -R * "$_installpath"
+ install -Dm644 "${srcdir}"/license.txt "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
+}
+
+# vim:set ts=2 sw=2 et: