summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 19:41:59 +0200
committerDaniel Nagy2015-06-08 19:41:59 +0200
commit81546171b8a0793fb0bbe67753e51d7e2093beaa (patch)
tree81778c7a63fd1880f9950be50d8f3c77a312aaba /PKGBUILD
downloadaur-vim-eclipse.tar.gz
import to aur4
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..bb6050af5b28
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+
+pkgname=vim-eclipse
+pkgver=1.0.2
+_scriptid=6890
+pkgrel=3
+pkgdesc="while typing a C function, a prototype is shown (man3 based)"
+arch=("i686" "x86_64")
+url="http://www.vim.org/scripts/script.php?script_id=1802"
+license=('custom')
+depends=(vim)
+groups=('vim-plugins')
+install=vimdoc.install
+source=(eclipse.vim::http://www.vim.org/scripts/download_script.php?src_id=${_scriptid}
+ license.txt)
+md5sums=('e132f1c1487c7bfc2b239ce9d3669b8f'
+ 'efbd5986e691ce8c876fb86e8f5961ea')
+
+package() {
+ install -Dm755 "${srcdir}"/eclipse.vim "${pkgdir}"/usr/share/vim/colors/eclipse.vim
+ install -Dm644 "${srcdir}"/license.txt "${pkgdir}"/usr/share/licenses/${pkgname}/license.txt
+}