summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThomas Dziedzic2013-08-30 02:23:18 +0000
committerEli Schwartz2015-07-08 13:16:06 -0400
commit50bea6f3e5db70b16d232bd5aba90053a997267d (patch)
tree3f1e368bd02fc25390f71ee00fd843e499e5b00b /PKGBUILD
downloadaur-50bea6f3e5db70b16d232bd5aba90053a997267d.tar.gz
Initial upload: vim-eunuch v1.0.5.g6a4d193-1
Imported old history from aur-mirror: updated on Fri Aug 30 02:23:15 UTC 2013 filter-branch: add .SRCINFO
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..540bc4a868d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=vim-eunuch
+_gitname='vim-eunuch'
+pkgver=v1.0.5.g6a4d193
+pkgrel=1
+pkgdesc="Vim sugar for the UNIX shell commands that need it the most, by tpope"
+arch=('any')
+depends=('vim')
+makedepends=('git')
+groups=('vim-plugins')
+url="https://github.com/tpope/vim-eunuch"
+license=('custom:vim')
+source=(git+https://github.com/tpope/vim-eunuch)
+sha256sums=('SKIP')
+provides=('vim-eunuch')
+conflicts=('vim-eunuch')
+install=vimdoc.install
+
+pkgver() {
+ cd $_gitname
+ git describe --always | sed 's|-|.|g'
+}
+
+prepare() {
+ cd $_gitname
+
+ msg 'Removing unneeded files...'
+ rm -f README.markdown
+}
+
+package() {
+ cd $_gitname
+
+ msg 'Installing...'
+ install -dm 755 ${pkgdir}/usr/share/vim/vimfiles/
+ tar -c . | tar -x -C ${pkgdir}/usr/share/vim/vimfiles
+
+ msg 'Cleaning up pkgdir...'
+ find "$pkgdir" -type d -name .git -exec rm -r '{}' +
+ find "$pkgdir" -type f -name .gitignore -exec rm -r '{}' +
+}