summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThomas Dziedzic2013-08-30 04:20:59 +0000
committerEli Schwartz2015-07-08 13:17:55 -0400
commit9d33c247fece004dbab108e4a20fae89ec4baea4 (patch)
tree99dd99bb06a8128c54cde55ae9cb97b3e58a0914 /PKGBUILD
parent50bea6f3e5db70b16d232bd5aba90053a997267d (diff)
downloadaur-9d33c247fece004dbab108e4a20fae89ec4baea4.tar.gz
upgpkg: vim-eunuch 1.0-1
Imported old history from aur-mirror: updated on Fri Aug 30 04:20:58 UTC 2013 filter-branch: add .SRCINFO
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 9 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 540bc4a868d1..cb7b02bc313e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,28 @@
# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
pkgname=vim-eunuch
-_gitname='vim-eunuch'
-pkgver=v1.0.5.g6a4d193
+pkgver=1.0
+_srcid=18948
pkgrel=1
pkgdesc="Vim sugar for the UNIX shell commands that need it the most, by tpope"
arch=('any')
depends=('vim')
makedepends=('git')
groups=('vim-plugins')
-url="https://github.com/tpope/vim-eunuch"
+url="http://www.vim.org/scripts/script.php?script_id=4300"
license=('custom:vim')
-source=(git+https://github.com/tpope/vim-eunuch)
-sha256sums=('SKIP')
+source=(${pkgname}.zip::http://www.vim.org/scripts/download_script.php?src_id=${_srcid})
+sha256sums=('e2280726aa8e6ee108d2e3f46f8a5fd3f206561ceae3faa8e10f4c5c4f31e9c5')
provides=('vim-eunuch')
-conflicts=('vim-eunuch')
+conflicts=('vim-eunuch-git')
install=vimdoc.install
-pkgver() {
- cd $_gitname
- git describe --always | sed 's|-|.|g'
-}
-
-prepare() {
- cd $_gitname
-
- msg 'Removing unneeded files...'
- rm -f README.markdown
-}
-
package() {
- cd $_gitname
+ cd "$srcdir"
+
+ rm ${pkgname}.zip
msg 'Installing...'
install -dm 755 ${pkgdir}/usr/share/vim/vimfiles/
tar -c . | tar -x -C ${pkgdir}/usr/share/vim/vimfiles
-
- msg 'Cleaning up pkgdir...'
- find "$pkgdir" -type d -name .git -exec rm -r '{}' +
- find "$pkgdir" -type f -name .gitignore -exec rm -r '{}' +
}