diff options
author | Yiyao Yu | 2019-06-23 11:25:14 +0800 |
---|---|---|
committer | Yiyao Yu | 2019-06-23 11:26:50 +0800 |
commit | 3a7a095f7a1d814c249fccb5c03f0c874b47a0ac (patch) | |
tree | e53151dbc4dbe04aa5eab4bb136d9396dae23017 /PKGBUILD | |
parent | f5d8ea9d0325c733224dd9b25d5d14b412f140a9 (diff) | |
download | aur-3a7a095f7a1d814c249fccb5c03f0c874b47a0ac.tar.gz |
Added license.txt, made pkgbuild better match non-git version
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 22 |
1 files changed, 12 insertions, 10 deletions
@@ -2,21 +2,23 @@ # Contributor: Sam Stuewe <halosghost at archlinux dot info> # Contributor: M Rawash <mrawash@gmail.com> # Contributor: János Illés <ijanos@gmail.com> + _pkgname=vim-fugitive pkgname="${_pkgname}-git" pkgver=2.5.139.g6d42c7d -pkgrel=1 -pkgdesc='A vim git wrapper so awesome, it should be illegal.' -arch=('any') +pkgrel=2 +pkgdesc='Git wrapper so awesome, it should be illegal.' url='https://github.com/tpope/vim-fugitive' +arch=('any') license=('custom:vim') -groups=('vim-plugins') depends=('vim' 'git') -conflicts=('vim-fugitive') +groups=('vim-plugins') provides=('vim-fugitive') -makedepends=('git') -source=("${_pkgname}::git+${url}.git") -sha256sums=('SKIP') +conflicts=('vim-fugitive') +source=("${_pkgname}::git+${url}.git" + license.txt) +sha256sums=('SKIP' + '446c67d93c43addf076fe103a71844c2d875d478f82186436567dd221f2652f3') pkgver() { cd "${srcdir}/${_pkgname}" @@ -29,8 +31,8 @@ package() { find autoload doc ftdetect plugin syntax -type f -exec \ install -Dm 644 '{}' "${pkgdir}/usr/share/vim/vimfiles/{}" \; - install -Dm 644 doc/fugitive.txt \ - "${pkgdir}/usr/share/licenses/${_pkgname}/fugitive.txt" + install -Dm 644 "${srcdir}/license.txt" \ + "${pkgdir}/usr/share/licenses/${_pkgname}/license.txt" } # vim:set et ts=2 sw=2 tw=79: |