summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Herzberg2018-08-21 13:00:32 +0100
committerMichael Herzberg2018-08-21 13:00:32 +0100
commit6ecd4106155dff0c765b34d4de7436d7c6ba358c (patch)
tree1cb0babee35f3f212a22d1c7e5e3cb8facb1835e /PKGBUILD
downloadaur-6ecd4106155dff0c765b34d4de7436d7c6ba358c.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c36183bbd021
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Michael Herzberg <{firstname}@{firstinitial}{lastname}.de>
+
+pkgname=vim-fzf-git
+pkgver=r327.f39c92b
+pkgrel=1
+pkgdesc='Vim plugin that integrates fzf, the fuzzy file finder'
+arch=('any')
+license=('MIT')
+url='https://github.com/junegunn/fzf.vim'
+depends=('vim' 'fzf')
+makedepends=('git')
+source=('git+https://github.com/junegunn/fzf.vim')
+md5sums=('SKIP')
+
+pkgver() {
+ cd fzf.vim
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd fzf.vim
+ install -Dm644 plugin/fzf.vim "${pkgdir}/usr/share/vim/vimfiles/plugin/fzf/fzf.vim"
+ cp -R autoload bin doc "${pkgdir}/usr/share/vim/vimfiles/"
+}