summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVicente Reyes2018-03-30 12:38:32 -0300
committerVicente Reyes2018-03-30 12:38:32 -0300
commitbe7b25871d508913fb9000c68b951b6ca2a586c3 (patch)
treeded939118d31515cab748f9f68d71a2c7c605be7 /PKGBUILD
downloadaur-vim-hoogle.tar.gz
added vim-hoogle plugin, v1.3 release 1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd3ff75b1bb2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Vicente Reyes <vreyesvaldivieso at gmail dot com>
+
+pkgname=vim-hoogle
+pkgver=1.3
+pkgrel=1
+pkgdesc='Search haskell documentation from vim'
+arch=('any')
+url='http://www.vim.org/scripts/script.php?script_id=2672'
+license=('unknown')
+depends=('vim')
+optdepends=('hoogle')
+groups=('vim-plugins')
+source=("$pkgname.vim::http://www.vim.org/scripts/download_script.php?src_id=15024")
+install='vimdoc.install'
+md5sums=('ce94fb9e77eb3d3f10bbd9df1834cdf7')
+
+package() {
+ cd "${pkgname}"
+ # See https://github.com/Twinside/vim-hoogle/issues/10
+ # I'm open to better solutions
+ vim -c "set fileformat=unix|wq" plugin/hoogle.vim
+ vim -c "set fileformat=unix|wq" doc/hoogle.vim
+
+ install -Dm644 doc/hoogle.txt "${pkgdir}/usr/share/vim/vimfiles/doc/hoogle.txt"
+ install -Dm644 plugin/hoogle.vim "${pkgdir}/usr/share/vim/vimfiles/plugin/hoogle.vim"
+}