summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 19:36:21 +0200
committerDaniel Nagy2015-06-08 19:36:21 +0200
commit864f240ba74e90e7fd0cc6d903ae56bc4d6b1da0 (patch)
treef84b515856383f88475864edaa209b68ff18034a /PKGBUILD
downloadaur-vim-jquery.tar.gz
import to aur4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c31206631895
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+# Contributor: Adam Russell <adamlr6+arch@gmail.com>
+# Contributor: Laszlo Papp <djszapi @ gmail dot com>
+
+pkgname=vim-jquery
+pkgver=0.5.2
+pkgrel=2
+_scriptid=15752
+pkgdesc="Syntax file for jQuery"
+arch=('any')
+url="http://www.vim.org/scripts/script.php?script_id=2416"
+license=('unknown')
+depends=('vim')
+groups=('vim-plugins')
+install=vim-jquery.install
+source=(jquery.vim::http://www.vim.org/scripts/download_script.php?src_id=$_scriptid)
+md5sums=('61056989ccd7cd0aa207a24681c52fa5')
+
+package() {
+ cd "${srcdir}"
+ local _installpath="${pkgdir}/usr/share/vim/vimfiles"
+ install -Dm644 jquery.vim "${_installpath}"/syntax/jquery.vim
+}