summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLiao Junxuan2022-04-04 22:59:35 +0800
committerLiao Junxuan2022-04-04 23:03:31 +0800
commit183cbf60071e8547b5a4ef29a5760bcd8f0a9a82 (patch)
tree3f48529c684a0aac79260c38db8cab6428ffbb10 /PKGBUILD
downloadaur-183cbf60071e8547b5a4ef29a5760bcd8f0a9a82.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..edf380ac1ef7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Liao Junxuan <mikeljx at 126 dot com>
+pkgname=vim-localvimrc-git
+pkgver=r238.4c768d2
+pkgrel=1
+pkgdesc="Search local vimrc files in the tree and load them."
+arch=('any')
+url="https://github.com/embear/vim-localvimrc"
+license=()
+groups=()
+depends=('vim-plugin-runtime')
+makedepends=('git')
+source=("git+https://github.com/embear/vim-localvimrc.git#branch=master")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ local _installpath="${pkgdir}/usr/share/vim/vimfiles"
+ install -d "${_installpath}"
+ find doc plugin -type f -exec \
+ install -Dm 644 '{}' "${pkgdir}/usr/share/vim/vimfiles/{}" \;
+}