summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthew Gamble2015-09-16 22:15:31 +1000
committerMatthew Gamble2015-09-16 22:15:31 +1000
commit5a407d598084c35faf2d11b055b4c3a88bb3deff (patch)
treebf51b5be1cf03f71305886aa1ad2d8b699520f3f /PKGBUILD
downloadaur-vim-pacmanlog.tar.gz
Initial commit of vim-pacmanlog to AUR4
This is a migration of vim-pacmanlog-git, which is why the original maintainer is credited in the PKGBUILD. I changed it from not being a git package because I didn't really see a point for keeping it like that when every release is tagged sensibly and there aren't frequent updates to the git repository.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e454405ce99
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Matthew Gamble
+# Contributer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=vim-pacmanlog
+pkgver=1.2
+pkgrel=1
+pkgdesc="Vim syntax highlighting for Pacman log files"
+arch=('any')
+depends=('vim')
+makedepends=('git')
+groups=('vim-plugins')
+url="https://github.com/vim-scripts/pacmanlog.vim"
+license=('custom:vim')
+source=("https://github.com/vim-scripts/pacmanlog.vim/archive/${pkgver}.tar.gz")
+sha256sums=('b0fac7971e3b0ceac765ec69ba2b47cefc18fdbb8c04fc7856955dc71b22532e')
+conflicts=('vim-pacmanlog-git')
+install=vimdoc.install
+
+package() {
+ cd "pacmanlog.vim-${pkgver}"
+
+ msg 'Installing documentation...'
+ install -Dm 644 README "$pkgdir/usr/share/doc/vim-pacmanlog/README"
+
+ msg 'Installing appdirs...'
+ install -dm 755 "$pkgdir/usr/share/vim/vimfiles"
+ for _appdir in syntax; do
+ cp -dpr --no-preserve=ownership $_appdir "$pkgdir/usr/share/vim/vimfiles/$_appdir"
+ done
+
+ msg 'Cleaning up pkgdir...'
+ find "$pkgdir" -type d -name .git -exec rm -r '{}' +
+}