summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Blakeney2023-09-02 11:46:49 +1000
committerMark Blakeney2023-09-02 11:46:49 +1000
commita8579d3ea95f322b20348260493175be798b7a55 (patch)
treeeb55da1e8bd54ab8f3833d60f84d2f1426ba833e /PKGBUILD
parentfae8c0041068e52374457d0c8706f0bb32052890 (diff)
downloadaur-vim-plugins-profiler.tar.gz
Update to 1.16
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 31d82671f23b..578b1dfbac8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: mark.blakeney at bullet-systems dot net
pkgname=vim-plugins-profiler
-pkgver=1.15
+pkgver=1.16
pkgrel=1
pkgdesc="Utility to output a sorted list of VIM plugin startup times in millisec."
url="https://github.com/bulletmark/$pkgname"
license=(GPL3)
arch=(any)
-depends=("python>=3.5")
-makedepends=(python-setuptools python-build python-installer python-wheel)
+depends=("python>=3.6")
+makedepends=(python-setuptools python-build python-installer
+ python-wheel python-setuptools-scm)
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-md5sums=('57c6fedf1146f8bc1a92c14279d7fa41')
+md5sums=('dac3136d5452d3909da3820058368e28')
build() {
cd "$srcdir/$pkgname-$pkgver"
- python -m build --wheel --no-isolation
+ SETUPTOOLS_SCM_PRETEND_VERSION="$pkgver" python -m build --wheel --no-isolation
}
package() {