summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRhinoceros2017-03-31 16:45:58 +1100
committerRhinoceros2017-03-31 16:45:58 +1100
commit167597b824d099ce6e15fc63c9cfd7c822420807 (patch)
treecbae5fbe158ac3592bc05ed5b3adadeb1867592c /PKGBUILD
parent094055dd478dcecc65feb6988d2d214f6f021566 (diff)
downloadaur-167597b824d099ce6e15fc63c9cfd7c822420807.tar.gz
Update to r180.b95b04f-2
* Add patch to rename "on-disk version" to something more precise https://github.com/chrisbra/Recover.vim/issues/47
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cf17977ec2fd..6e115fcbed4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Rhinoceros <https://aur.archlinux.org/account/rhinoceros>
pkgname=vim-recover-git
-pkgver=r170.eed74fb
-pkgrel=1
+pkgver=r180.b95b04f
+pkgrel=2
pkgdesc='A Vim plugin to show a diff, whenever recovering a buffer'
arch=('any')
url='http://www.vim.org/scripts/script.php?script_id=3068'
@@ -14,14 +14,22 @@ makedepends=('git')
provides=('vim-recover')
conflicts=('vim-recover')
install=vimdoc.install
-source=('git+https://github.com/chrisbra/Recover.vim.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/chrisbra/Recover.vim.git'
+ 'fix_nomenclature.patch')
+sha256sums=('SKIP'
+ '67f2652b757065f927ee4b09135e6e0de6cc5903a2d3ccd1db2fe3bd63ca807a')
pkgver() {
cd 'Recover.vim'
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd 'Recover.vim'
+ # rename "on-disk version" to something more precise https://github.com/chrisbra/Recover.vim/issues/47
+ patch -p0 <../../fix_nomenclature.patch
+}
+
package() {
_installpath="${pkgdir}/usr/share/vim/vimfiles"
mkdir -p "${_installpath}"