summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEli Schwartz2015-06-14 13:50:31 -0500
committerEli Schwartz2015-06-22 20:14:41 -0500
commit7782e48bc3999170b1d85c0b29a59325c37b3c33 (patch)
tree91c349484d5716896ebe766171904421a94168cd /PKGBUILD
downloadaur-7782e48bc3999170b1d85c0b29a59325c37b3c33.tar.gz
Initial upload: vim-sensible 1.1-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e41b67feab15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Eli Schwartz <eschwartz93@gmail.com>
+
+pkgname=vim-sensible
+pkgver=1.1
+pkgrel=1
+pkgdesc="Vim sugar for the UNIX shell commands that need it the most, by tpope"
+arch=('any')
+url="https://github.com/tpope/${pkgname}"
+license=('custom:vim')
+groups=('vim-plugins')
+depends=('vim')
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('c503b7e45659749a1644fbe04c9000446984a862582fa05f529bcf5543cf3341')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -dm755 "${pkgdir}/usr/share/vim/vimfiles"
+ find * -maxdepth 0 -type d -exec cp -rt "${pkgdir}/usr/share/vim/vimfiles" '{}' \+
+}