summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEli Schwartz2017-07-20 12:12:07 -0400
committerEli Schwartz2017-07-20 12:12:07 -0400
commit3f375c560b09f213fe8e76f528808d6355e5e71a (patch)
treeebb40350d5db1ef5b42ecae29889134322c7bd7c /PKGBUILD
parentf6f4d19e2ab039b11236f201d1300ce1aa7ac5f6 (diff)
downloadaur-3f375c560b09f213fe8e76f528808d6355e5e71a.tar.gz
Mass cleanup
- switch my email address - switch git:// to git+https:// - fix download filenames for $pkgver.tar.gz downloads - add comment pointing to my PKGBUILD repo - misc. code style improvements Some *-git pkgver bumps came along for the ride as well.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c447c42a1525..e26864121bad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,9 @@
-# Maintainer: Eli Schwartz <eschwartz93@gmail.com>
+# Maintainer: Eli Schwartz <eschwartz@archlinux.org>
+
+# All my PKGBUILDs are managed at https://github.com/eli-schwartz/pkgbuilds
pkgname=vim-sensible-git
-pkgver=1.1.r4.gd0beb8a
+pkgver=1.1.r15.g49ee364
pkgrel=1
pkgdesc="vim defaults everyone can agree on"
arch=('any')
@@ -12,12 +14,12 @@ depends=('vim')
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=("git://github.com/tpope/${pkgname%-git}.git")
+source=("git+${url}.git")
sha512sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgname%-git}"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | cut -c2-
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {