summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRhinoceros2015-08-11 20:35:08 +1000
committerRhinoceros2015-08-11 20:35:08 +1000
commite55c448b1e25f75e0d323677974f48655e3d8cdc (patch)
tree666e9ec0cf00546fc3f5eca4cf39f551fc4e1c98 /PKGBUILD
parent07bde278fcfe50904cf29cc7a3db7a6eb0a13f7c (diff)
downloadaur-e55c448b1e25f75e0d323677974f48655e3d8cdc.tar.gz
Upgrade to 1:1.0.r1.ga58f92e-1
* Fix pkgver() as per Arch wiki recommendations * Bumped epoch, so that new (correct) version is newer than previous version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1ed801d030bb..183079b3572d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
# Contributor: Mizuchi <ytj000+AUR@gmail.com>
pkgname=vim-startify-git
-pkgver=1.8
+pkgver=1.0.r1.ga58f92e
pkgrel=1
+epoch=1
pkgdesc='A fancy start screen for Vim.'
arch=('any')
url='https://github.com/mhinz/vim-startify'
@@ -17,6 +18,12 @@ install='vimdoc.install'
source=("git+https://github.com/mhinz/${pkgname%-git}.git")
sha256sums=('SKIP')
+pkgver() {
+ cd "$pkgname"
+ # cutting off 'v' prefix from the git tag
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
package() {
cd ${pkgname%-git}
_installpath="${pkgdir}/usr/share/vim/vimfiles"