summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Wagner2015-06-14 11:06:21 -0400
committerAndreas Wagner2015-06-14 11:06:21 -0400
commit3d593a5befe0f07d57753f9d70bdb91afb052dbd (patch)
tree334e66b325df2f4148945f7503fec74d03cd27b0 /PKGBUILD
downloadaur-3d593a5befe0f07d57753f9d70bdb91afb052dbd.tar.gz
Initial import.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dbbf68287d8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Andreas B. Wagner <AndreasBWagner@pointfree.net> awagner on irc.freenode.net
+pkgname=vim-syntastic-git
+pkgver=3.6.0_94_gb8682c3
+pkgrel=1
+pkgdesc="Syntax checking hacks for vim"
+arch=('any')
+url="https://github.com/scrooloose/syntastic"
+license=('WTFPLv2')
+groups=('vim-plugins')
+depends=('vim-runtime')
+makedepends=('git' 'rake')
+provides=('vim-syntastic')
+conflicts=('vim-syntastic')
+install=vimdoc.install
+source=("git+https://github.com/scrooloose/syntastic.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd syntastic
+ echo $(git describe --tags | sed 's#-#_#g;s#v##')
+}
+
+package() {
+ mkdir -p $pkgdir/usr/share/vim/vimfiles/{plugin,doc,autoload/syntastic/,syntax_checkers}
+ cd "$srcdir/syntastic"
+ cp -r plugin/* $pkgdir/usr/share/vim/vimfiles/plugin/
+ cp doc/syntastic.txt $pkgdir/usr/share/vim/vimfiles/doc/
+ cp autoload/syntastic/* $pkgdir/usr/share/vim/vimfiles/autoload/syntastic/
+ cp -r syntax_checkers/* $pkgdir/usr/share/vim/vimfiles/syntax_checkers/
+}
+
+# vim:set ts=2 sw=2 et: