summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel YC Lin2015-06-13 11:47:04 +0800
committerDaniel YC Lin2015-06-13 11:47:04 +0800
commite395b5b84f05cdc363fb96fa2820ab1a1cb2f2f4 (patch)
treecd8a5ac403a4a7f76c53a8ff97572e0e898b3d5f /PKGBUILD
downloadaur-e395b5b84f05cdc363fb96fa2820ab1a1cb2f2f4.tar.gz
merge to aur4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..acc9b3194c25
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Contributor: Daniel YC Lin <dlin (at) gmail>
+# Maintainer: Daniel YC Lin <dlin.tw at gmail>
+
+pkgname=vim-tabular-git
+pkgver=r29.60f2564
+pkgrel=1
+pkgdesc="Vim script for text filtering and alignment"
+arch=('any')
+url="https://github.com/godlygeek/tabular"
+license='custom:BSD 3-Clause'
+makedepends=('git')
+depends=('vim')
+provides=('vim-tabular')
+install=vim-plugin.install
+source=('repo::git+https://github.com/godlygeek/tabular.git')
+md5sums=('SKIP')
+pkgver() {
+ cd "$srcdir/repo"
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+package() {
+ cd $srcdir/repo
+
+ install -dm755 $pkgdir/usr/share/vim/vimfiles/after/plugin
+ install -dm755 $pkgdir/usr/share/vim/vimfiles/{autoload,doc,plugin}
+
+ install -Dm644 after/plugin/* $pkgdir/usr/share/vim/vimfiles/after/plugin/
+ install -Dm644 autoload/* $pkgdir/usr/share/vim/vimfiles/autoload/
+ install -Dm644 doc/* $pkgdir/usr/share/vim/vimfiles/doc/
+ install -Dm644 plugin/* $pkgdir/usr/share/vim/vimfiles/plugin/
+
+ sed -n '/License:/,/ DAMAGE/p' plugin/Tabular.vim > LICENSE
+
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}