summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnkit R Gadiya2018-02-22 22:29:17 +0530
committerAnkit R Gadiya2018-02-22 22:29:17 +0530
commit4686dc4075d3ab830fe46f07176d6e5a82c24f14 (patch)
tree2eac3b604ca97132ffdef81aaafbe31104e182a5 /PKGBUILD
parentce8719354b9853990e64f81881b6ec703490c3bb (diff)
downloadaur-4686dc4075d3ab830fe46f07176d6e5a82c24f14.tar.gz
Update: Added License, Renamed source tarball and removed an unnecessary command
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 306c2603f6ab..3e94cbc28020 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=tcomment-vim
pkgver=3.08.1
-pkgrel=1
+pkgrel=2
pkgdesc="An extensible & universal comment vim-plugin that also
handles embedded filetypes"
license=('GPL3')
@@ -10,17 +10,17 @@ arch=('any')
url="https://github.com/tomtom/tcomment_vim"
depends=('vim')
groups=('vim-plugins')
-source=("https://github.com/tomtom/${pkgname/-/_}/archive/${pkgver}.tar.gz")
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/tomtom/${pkgname/-/_}/archive/${pkgver}.tar.gz")
md5sums=('6ea8f4ce78411efba444a0218e111219')
package() {
-
- install -d "${pkgdir}/usr/share/vim/vimfiles/"{doc,plugin,autoload}
-
install -Dm755 "${srcdir}/${pkgname/-/_}-${pkgver}/plugin/tcomment.vim" \
"${pkgdir}/usr/share/vim/vimfiles/plugin/tcomment.vim"
install -Dm755 "${srcdir}/${pkgname/-/_}-${pkgver}/doc/tcomment.txt" \
"${pkgdir}/usr/share/vim/vimfiles/doc/tcomment.txt"
install -Dm755 "${srcdir}/${pkgname/-/_}-${pkgver}/autoload/tcomment.vim" \
"${pkgdir}/usr/share/vim/vimfiles/autoload/tcomment.vim"
+
+ install -Dm644 "${srcdir}/${pkgname/-/_}-${pkgver}/LICENSE.TXT" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}