summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoraksr2015-06-28 16:14:22 +0200
committeraksr2015-06-28 16:14:22 +0200
commit61c4f0d9fe24775c645b9e88e6d6a6e7af2d6515 (patch)
treeceb00c2986bc5927f2da7136b79649e97f2a23fd /PKGBUILD
downloadaur-61c4f0d9fe24775c645b9e88e6d6a6e7af2d6515.tar.gz
Start.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00445710d5da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=vim-tomorrow-theme-git
+pkgver=v1.0.r20.g5d66e71
+pkgrel=1
+pkgdesc="Tomorrow Theme for Vim"
+arch=('any')
+url="https://github.com/chriskempson/vim-tomorrow-theme"
+license=('MIT')
+groups=('vim-plugins')
+depends=('vim')
+makedepends=('git')
+provides=()
+#conflicts=('vim-colorsamplerpack')
+replaces=()
+backup=()
+options=()
+install=""
+source=("$pkgname::git+https://github.com/chriskempson/vim-tomorrow-theme.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git describe --long | sed -E 's/^v//g;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$pkgname/colors"
+ install -Dm644 Tomorrow.vim $pkgdir/usr/share/vim/vimfiles/colors/Tomorrow.vim
+ install -Dm644 Tomorrow-Night.vim $pkgdir/usr/share/vim/vimfiles/colors/Tomorrow-Night.vim
+ install -Dm644 Tomorrow-Night-Blue.vim $pkgdir/usr/share/vim/vimfiles/colors/Tomorrow-Night-Blue.vim
+ install -Dm644 Tomorrow-Night-Bright.vim $pkgdir/usr/share/vim/vimfiles/colors/Tomorrow-Night-Bright.vim
+ install -Dm644 Tomorrow-Night-Eighties.vim $pkgdir/usr/share/vim/vimfiles/colors/Tomorrow-Night-Eighties.vim
+}
+