summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdam Q2015-07-30 10:45:26 +0800
committerAdam Q2015-07-30 10:45:26 +0800
commit475740e3f75273c9011cfd2111ed5141ad887b60 (patch)
tree577272a9ebe8994a1997fd1fdc0d1242c421485c /PKGBUILD
downloadaur-475740e3f75273c9011cfd2111ed5141ad887b60.tar.gz
Initial commit using new aur4 infrastructure.
Signed-off-by: Adam Q <adam900710@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34e4eb673bc9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Contributor: Piotr Rogoża <rogoza dot piotr at gmail dot com>
+pkgname=vim-vim-support
+pkgver=2.3
+_scriptid=22356
+pkgrel=1
+pkgdesc='Vim-IDE implements a vim script IDE with hotkeys and snippets from the same author of
+vim-{bash,perl,lua,c}-support'
+arch=('any')
+url='http://vim.org/scripts/script.php?script_id=3931'
+license=('custom:vim')
+groups=('vim-plugins')
+depends=('vim')
+install='vimdoc.install'
+source=("${pkgname}.zip::http://www.vim.org/scripts/download_script.php?src_id=$_scriptid")
+
+package() {
+ cd "$srcdir"
+ _vim_dir='usr/share/vim/vimfiles'
+
+ install -dm755 ${pkgdir}/${_vim_dir} || return 1
+
+ tar -c ./ --exclude ${pkgname}.zip | tar -x -C ${pkgdir}/${_vim_dir} || return 1
+
+}
+
+md5sums=('6946539f736dc47acaef682e219beda8')
+
+# vim:set ts=2 sw=2 et ft=sh tw=100: