summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSainnhepark2020-08-03 18:39:29 +0800
committerSainnhepark2020-08-03 18:39:29 +0800
commitaad2ff189b2255ee726239a561d6681dcb4647b0 (patch)
tree8dd0013a92207d40f6f72640e9bc7bfe1c7394be /PKGBUILD
parentba6f52df68388e18f5690b064c7296b885e4081f (diff)
downloadaur-vim-vista-git.tar.gz
remove hook
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 3 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 25ecdf130ff7..e0514da46f00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,10 +14,8 @@ optdepends=('ctags: ctags support'
'fzf: for searching symbols/tags')
provides=('vim-vista')
conflicts=('vim-vista')
-source=("${_pkgname}::git+https://github.com/liuchengxu/vista.vim.git"
- "${_pkgname}-vim-doc.hook")
-sha256sums=('SKIP'
- '4888f23eae41c3bc63ee39e018a1434fac8ad62f3af5a9b4cb500121becc7f6c')
+source=("${_pkgname}::git+https://github.com/liuchengxu/vista.vim.git")
+sha256sums=('SKIP')
makedepends=('git')
_packdir="usr/share/vim/vimfiles/pack/${_pkgname}/start/${_pkgname}"
_variant='vim'
@@ -27,16 +25,11 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-build() {
- cd "${srcdir}/${_pkgname}"
- touch doc/tags
-}
-
package() {
cd "${srcdir}/${_pkgname}"
+ vim -es --cmd ":helptags doc" --cmd ":q"
find autoload doc plugin syntax -type f -exec \
install -Dm 644 '{}' "${pkgdir}/${_packdir}/{}" \;
install -Dm 644 "${srcdir}/${_pkgname}/LICENSE" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm 644 "${srcdir}/${_pkgname}-${_variant}-doc.hook" "${pkgdir}/usr/share/libalpm/hooks/${_pkgname}-${_variant}-doc.hook"
}