summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJan-Tarek Butt2016-07-01 02:32:13 +0200
committerJan-Tarek Butt2016-07-01 02:32:13 +0200
commit9d3904377955a79b0f0d26ea56b1ef14b5708fe8 (patch)
tree10e16f3eb4d6103c4821e541f0328431b202009a /PKGBUILD
parent607d9263c5e91ba306e32281225c1c9237f9aedd (diff)
downloadaur-9d3904377955a79b0f0d26ea56b1ef14b5708fe8.tar.gz
add dynamic core counting and dynamic muilticore build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5f005fffa1b2..09ed29cc6c5e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -123,6 +123,13 @@ prepare() {
fi
}
+# investigating number of logic cores
+if [[ -f /proc/cpuinfo ]]; then
+ CPUS=$(grep -c processor /proc/cpuinfo)
+else
+ CPUS=1
+fi
+
build() {
# https://github.com/Valloric/ycmd/blob/master/build.py {{{
@@ -130,7 +137,7 @@ build() {
mkdir -p "$srcdir/ycmd_build"
cd "$srcdir/ycmd_build"
cmake -G "Unix Makefiles" -D${_COMPLETER}=1 . "$srcdir/YouCompleteMe/third_party/ycmd/cpp"
- make ycm_core
+ make -j $((CPUS*2)) ycm_core
msg2 'Building OmniSharp completer...' # BuildOmniSharp()
cd "$srcdir/YouCompleteMe/third_party/ycmd/third_party/OmniSharpServer"