summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJason Ryan2015-07-07 11:55:43 +1200
committerJason Ryan2015-07-08 10:17:38 +1200
commitb2ddad261a7f6f7d42bac1bc33234fec998e0c91 (patch)
tree6216e6aafcba065e39c76f7e873e8384f41e62a6 /PKGBUILD
downloadaur-b2ddad261a7f6f7d42bac1bc33234fec998e0c91.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d3c273017dd0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: jason ryan <jasonwryan@gmail.com>
+
+pkgname=vimb-git
+_pkgname=vimb
+pkgver=2.10.r6.g1a8f7e5
+pkgrel=1
+pkgdesc="Vimb is a lightweight WebKit-based browser"
+arch=('i686' 'x86_64')
+url="http://fanglingsu.github.io/vimb"
+license=('GPL3')
+depends=('webkitgtk2')
+conflicts=('vimb')
+source=('git://github.com/fanglingsu/vimb.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${_pkgname}"
+ make
+}
+
+package() {
+ cd "${_pkgname}"
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
+}
+