summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbegin-theadventure2023-11-13 00:39:45 +0100
committerbegin-theadventure2023-11-13 00:39:45 +0100
commit3f05197bd24e0eb057af56523af3c5ad47953a58 (patch)
treec4c3b7610efd3140cfb34063754aa1aba84910f7 /PKGBUILD
parent069c0d0e2504abe9d476c8cc3351ae70cc07d63d (diff)
downloadaur-3f05197bd24e0eb057af56523af3c5ad47953a58.tar.gz
2.4.0, cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 28 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aeb85e4aa45f..8ebb26ed76a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,33 @@
-# Maintainer: nb5p
+# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
+# Contributor: nb5p
+
pkgname=vimcdoc
-pkgver=2.3.0
+pkgver=2.4.0
pkgrel=1
-pkgdesc="Vim chinese documentation"
-arch=(any)
-depends=('vim')
+pkgdesc="Vim Chinese Documentation"
url="http://vimcdoc.sf.net"
-license=('GPL')
-source=("https://nchc.dl.sourceforge.net/project/vimcdoc/vimcdoc/vimcdoc-2.3.0.tar.gz")
-md5sums=('fdc9e9d35a1355423bcc5f75f7f5463c')
+url2="http://github.com/yianwillis/vimcdoc"
+arch=('any')
+license=('custom:vimcdoc')
+depends=('vim')
+source=("https://nchc.dl.sourceforge.net/project/vimcdoc/vimcdoc/vimcdoc-$pkgver.tar.gz")
+sha256sums=('08f7fb85dc5c7d2535749336d0268262d3a6be213a8bdf2d0de90073be187046')
+
package() {
- cd "${pkgname}-${pkgver}"
- local _dir="${pkgdir}/usr/share/vim/vimfiles"
- for __dir in *; do
- if [ -d "${__dir}" ]; then
- cd ${__dir}
- for __file in *; do
- if [ -f "${__file}" ]; then
- install -Dm 644 ${__file} ${_dir}/${__dir}/${__file}
- fi
- done
- cd ..
- fi
- done
+ cd vimcdoc-$pkgver
+ local _dir="$pkgdir/usr/share/vim/vimfiles"
+ for __dir in *; do
+ if [ -d "${__dir}" ]; then
+ cd ${__dir}
+ for __file in *; do
+ if [ -f "${__file}" ]; then
+ install -Dm644 ${__file} ${_dir}/${__dir}/${__file}
+ fi
+ done
+ cd ..
+ fi
+ done
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/vimcdoc"
+ rm -dr doc plugin syntax LICENSE VERSION vimcdoc.sh
+ install -Dm644 * -t "$pkgdir/usr/share/doc/vimcdoc"
}