summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authort0nedef2015-08-29 17:36:53 -0400
committert0nedef2015-08-29 17:36:53 -0400
commit88a81fc5035b36eb4f9c8283e6c26b2bd67dd255 (patch)
treecdfecf5c8fc9ecbbc44cc9ba947720ec9d7bf172 /PKGBUILD
downloadaur-vimeo-dl-git.tar.gz
moved to aur4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6694ac58a9db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Aaron Ali <t0nedef@causal.ca>
+pkgname=vimeo-dl-git
+pkgver=20130321
+pkgrel=2
+pkgdesc="A command line script to download vimeo videos"
+arch=('any')
+license=('custom')
+#url='http://ossguy.com/?p=841'
+url='https://github.com/johnteslade/vimeo-downloader'
+depends=('wget')
+makedepends=('git')
+conflicts=('vimeo-dl')
+provides=('vimeo-dl')
+replaces=('vimeo-dl')
+
+_gitroot="git://github.com/johnteslade/vimeo-downloader.git"
+_gitname="vimeo-downloader"
+
+build() {
+ cd ${srcdir}/
+ msg "Connecting to the GIT server...."
+ if [[ -d ${srcdir}/${_gitname} ]] ; then
+ cd ${_gitname}
+ git pull origin
+ msg "The local files are updated..."
+ else
+ git clone ${_gitroot}
+ fi
+ msg "GIT checkout done. Building."
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr/share/licenses/vimeo-dl
+ sed -n '/Copyright/,/ SOFTWARE\./p' ${srcdir}/${_gitname}/vimeo_downloader.sh > ${pkgdir}/usr/share/licenses/vimeo-dl/LICENSE
+ install -Dm644 ${srcdir}/${_gitname}/README.md ${pkgdir}/usr/share/vimeo-dl/README
+ install -Dm755 ${srcdir}/${_gitname}/vimeo_downloader.sh ${pkgdir}/usr/bin/vimeo_downloader.sh
+ ln -s vimeo_downloader.sh ${pkgdir}/usr/bin/vimeo-dl
+}
+#