summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEcho J2023-08-19 20:40:19 +0300
committerEcho J2023-08-19 20:40:19 +0300
commit6b6ed9a68a1cb78490ce580894a5c73ebcf5585c (patch)
tree891bac3fc4b012d3ffe5a0b1b76f849f224188ad /PKGBUILD
parent23b5668940ac18c4d9c4e12d2f716f500f5bd1bb (diff)
downloadaur-6b6ed9a68a1cb78490ce580894a5c73ebcf5585c.tar.gz
Required changes for v1.1.0 rewrite
Note: I have doubts about including MinGW GCC as a dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bc6a05771580..687c904c381a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,15 @@
_pkgname=vinegar
pkgname=vinegar-git
-pkgver=1.0.1.r5.gfc579cf
+pkgver=1.1.0.r1.ge4e8951
pkgrel=1
pkgdesc="A transparent wrapper for Roblox Player and Roblox Studio (Git version)"
arch=("x86_64")
url="https://github.com/vinegarhq/vinegar"
license=("GPL3")
depends=("glibc" "hicolor-icon-theme")
-makedepends=("git" "go")
+makedepends=("git" "go" "mingw-w64-gcc")
+optdepends=("wine: A required dependency (made optional for flexbility)")
conflicts=("vinegar")
source=("git+${url}")
sha256sums=("SKIP")
@@ -25,16 +26,19 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
- export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=vendor -modcacherw"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -modcacherw"
- make VERSION="${pkgver}" DESTDIR="${pkgdir}" PREFIX="/usr" vinegar
+ # Make sure Vinegar rebuilds
+ make clean
+
+ make DESTDIR="${pkgdir}" PREFIX="/usr" vinegar robloxmutexer
}
package() {
cd "${srcdir}/${_pkgname}"
# This does all the work (except for the optional LICENSE file)
- make VERSION="${pkgver}" DESTDIR="${pkgdir}" PREFIX="/usr" install
+ make DESTDIR="${pkgdir}" PREFIX="/usr" install install-robloxmutexer
# Install GPLv3 license (just in case)
install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"