summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcopygirl2023-08-10 11:28:11 +0200
committercopygirl2023-08-10 11:28:11 +0200
commit4db14378371d37d4a0c3b3aedd2619f307f2f802 (patch)
tree537e6ad784d47375869e6ed21d699ac130d1fb94 /PKGBUILD
parentfbe609bffe5d384def715c6ee0d3a6738b3c8afe (diff)
downloadaur-4db14378371d37d4a0c3b3aedd2619f307f2f802.tar.gz
New release 1.18.8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 21 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9c655411b6ce..4261b615542b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,26 +5,31 @@ pkgname=vintagestory
# "unstable" for release candidates and "pre" for testing releases before big updates.
_release=stable
# _pkgver is separate to allow specifying pre-release versions such as "-rc.1".
-_pkgver=1.18.7
+_pkgver=1.18.8
# makepkg doesn't support hyphens in pkgver. They'll be replaced with underscores.
pkgver=${_pkgver//-/_}
pkgrel=1
-pkgdesc="An in-development indie sandbox game about innovation and exploration"
+pkgdesc="Uncompromising wilderness survival sandbox game (requires paid account)"
arch=("any")
url="https://www.vintagestory.at/"
license=("custom")
-depends=("mono" "opengl-driver" "openal")
-source=("https://cdn.vintagestory.at/gamefiles/$_release/vs_archive_$_pkgver.tar.gz"
-# "https://account.vintagestory.at/files/$_release/vs_archive_$_pkgver.tar.gz" (alternative source)
- "vintagestory.desktop"
- "vintagestory.sh")
-md5sums=("71a926800a75b5ccc8ef2ceaa2bdcf67"
- "ab6680c4499b58b14aa36acc2ab4038a"
- "88627bf1e56df5cb72605c0e60ae9dcb")
+depends=("dotnet-runtime" "opengl-driver" "openal")
+source=("https://cdn.vintagestory.at/gamefiles/$_release/vs_client_linux-x64_$_pkgver.tar.gz"
+# "https://account.vintagestory.at/files/$_release/vs_client_linux-x64_$_pkgver.tar.gz" (alternative source)
+ "vintagestory.desktop")
+md5sums=("40e307ae1c0ebe6db1a95c375fb41ffc"
+ "26ff9ca4fb0a583589f26f2c274d4ec6")
prepare() {
+ # Remove install script provided by developers
+ rm "$pkgname"/install.sh
+ # Fix file permissions so other users can access them
+ find "$pkgname" -type f -exec chmod 644 {} \;
+ # Mark .sh files and executables as executable
+ chmod +x "$pkgname"/*.sh "$pkgname"/Vintagestory "$pkgname"/VintagestoryServer
# Create symbolic links for any assets (excluding fonts) containing non-lowercase letters
+ # Some asset files might include uppercase letters, but the game expects them to be all-lowercase
find "$pkgname"/assets/ -not -path "*/fonts/*" -regex ".*/.*[A-Z].*" | while read -r file; do
local filename="$(basename -- "$file")"
ln -sf "$filename" "${file%/*}"/"${filename,,}"
@@ -32,13 +37,14 @@ prepare() {
}
package() {
- # Copy terminal launcher script
- install -Dm755 "$pkgname".sh "$pkgdir"/usr/bin/"$pkgname"
# Copy application icon and .desktop launcher file
install -Dm644 "$pkgname"/assets/gameicon.xpm "$pkgdir"/usr/share/pixmaps/"$pkgname".xpm
install -Dm644 "$pkgname".desktop "$pkgdir"/usr/share/applications/"$pkgname".desktop
- # Copy fonts
+ # Copy fonts to /usr/share/fonts
install -Dm644 -t "$pkgdir"/usr/share/fonts/TTF/ "$pkgname"/assets/game/fonts/*.ttf
- # Move application files
- mv "$pkgname" "$pkgdir"/usr/share/"$pkgname"
+ # Copy all other application files
+ cp -rdp --no-preserve=ownership "$pkgname" "$pkgdir"/usr/share/"$pkgname"
+ # Create a symlink to run the game from terminal
+ install -dm 755 "${pkgdir}/usr/bin/" # Create directory first (required)
+ ln -s "/usr/share/${pkgname}/Vintagestory" "${pkgdir}/usr/bin/${pkgname}"
}