summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRicardo (XenGi) Band2022-07-15 11:26:49 +0200
committerRicardo (XenGi) Band2022-07-15 11:26:49 +0200
commit82fb4161f4ac58fccf3429dfe33d5d68d5a54a70 (patch)
tree3ad2e1d4359b2c39516aeac0709d274059a2d7a7 /PKGBUILD
parentf4831688be183e0fb450e95e4745870e1d1bf65f (diff)
downloadaur-82fb4161f4ac58fccf3429dfe33d5d68d5a54a70.tar.gz
fix dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8adc58f43c86..f02ba38beaa2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Ricardo Band <email@ricardo.band>
pkgname=virtualfish
pkgver=2.5.4
-pkgrel=2
+pkgrel=3
pkgdesc="Fish shell tool for managing Python virtual environments"
arch=("any")
url=https://github.com/justinmayer/virtualfish
license=("MIT")
-depends=("python-pkgconfig" "python-psutil" "python-virtualenv" "python-setuptools")
+depends=("fish>=3.1" "python>=3.6.2" "python-packaging>=21.3" "python-pkgconfig>=1.5" "python-psutil>=5.7" "python-virtualenv>=20")
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
sha256sums=('c8e256586d7a45ca461134a18d2fecfb7df7d32c104e9bd84d82570c6ef2ac3e')
@@ -16,8 +16,6 @@ build() {
}
package() {
- depends=("fish>=3.1")
-
cd "$srcdir/$pkgname-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}