summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 20:36:40 +0200
committerDaniel Nagy2015-06-08 20:36:40 +0200
commitd90299711eb2695b6469e8fc5fc5d58e16fab6cb (patch)
treeaa25719752b3b109f8ab29b8542a8d7c575495f6 /PKGBUILD
downloadaur-d90299711eb2695b6469e8fc5fc5d58e16fab6cb.tar.gz
import to aur4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..39b545d38354
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+
+pkgname=virtualsmartcard-git
+_gitname=virtualsmartcard
+pkgver=0
+pkgrel=1
+pkgdesc="Virtual Smart Card emulates a smart card and makes it accessible through PC/SC"
+url="http://sourceforge.net/projects/vsmartcard/"
+arch=('i686' 'x86_64')
+license=( "GPLv3" )
+conflicts=( $_gitname )
+provides=( $_gitname )
+depends=( "pcsclite" )
+makedepends=( "help2man" )
+source=( "$_gitname::git+http://git.code.sf.net/p/vsmartcard/git" )
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir"/$_gitname
+ # Use the tag of the last commit
+ git describe --always | sed 's|-|.|g'
+}
+
+build() {
+ cd "$srcdir"/$_gitname/virtualsmartcard
+ autoreconf --verbose --install
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir"/$_gitname/virtualsmartcard
+ make DESTDIR="$pkgdir" install
+}