summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgnunn12015-11-28 14:08:38 -0500
committergnunn12015-11-28 14:08:38 -0500
commit5d3322800d169735a521c6eccab72d41513e24f6 (patch)
tree6e46798e95f4b6241bd9ebaaac9ffea4ece789e0 /PKGBUILD
downloadaur-5d3322800d169735a521c6eccab72d41513e24f6.tar.gz
Initial Package Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d91e9c701e77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Gerald Nunn <gerald dot b dot nunn at gmail dot com>
+
+pkgname=visual-grep
+pkgver=0.21
+pkgrel=1
+pkgdesc="A GTK 3 based GUI for grep"
+arch=('x86_64')
+url="http://github.com/gnunn1/vgrep"
+license=('MPL')
+depends=('gtk3')
+source_x86_64=(https://github.com/gnunn1/vgrep/releases/download/$pkgver/vgrep.zip)
+md5sums_x86_64=('3ba187abf9fd60d8a218a1006ab5b875')
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/applications"
+ install -Dm755 vgrep "$pkgdir/usr/bin/vgrep"
+ install -Dm755 vgrep.desktop "$pkgdir/usr/share/applications"
+}