summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2019-04-24 15:04:57 +0200
committerbartus2019-04-24 15:04:57 +0200
commit9b731b95aafbb9f24f72b5d3e33e021d91862be6 (patch)
tree49eb55ad3c6f9e2c8005770f740a7795b48a41ec /PKGBUILD
parent083acdc6600861b1586910e65e32e93b02b671da (diff)
downloadaur-9b731b95aafbb9f24f72b5d3e33e021d91862be6.tar.gz
fix omission
remove debug flags comment out libjpeg swap
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ed3d4c0e5f54..78011c62e713 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,6 +4,7 @@
pkgname=('visual-sfm')
pkgver=0.5.26
pkgrel=4
+#options=(debug !strip !makeflags)
pkgdesc='A Visual Structure from Motion System; create 3d models from photos.'
arch=('x86_64')
url='http://ccwu.me/vsfm/'
@@ -24,7 +25,7 @@ md5sums=(
'c063c0236d8649b2281b334ecde73784'
'672f5cd6c1b4c08517409809b819c547'
)
-options=(debug !strip !makeflags)
+
build() {
msg "building Multicore Bundle Adjustment"
@@ -41,7 +42,11 @@ build() {
sed -i 's:$(LIB_DIR)/blas.a:-lblas:' makefile
sed -i 's:$(LIB_DIR)/libf2c.a:-lf2c:' makefile
sed -i 's:g++:g++-5:' makefile
-# sed -i 's:$(LIB_DIR)/libjpeg.a:-ljpeg:' makefile
+# sed -i 's:$(LIB_DIR)/libjpeg.a:-ljpeg:' makefile
+# Won't work with system libjpeg
+#Thread 56 "VisualSFM" received signal SIGSEGV, Segmentation fault.
+#[Switching to Thread 0x7fff72ffd700 (LWP 31903)]
+#0x00007ffff5bdb566 in jpeg_CreateDecompress () from /usr/lib/libjpeg.so.8
make
}