summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSeverin Kaderli2021-08-17 20:37:28 +0200
committerSeverin Kaderli2021-08-17 20:37:28 +0200
commit7b57896a3afbc2804bd136d890f6c22af3ca03c7 (patch)
treef850380726c4ed23efb4202ee3d03a41846dc6d7 /PKGBUILD
parentbc6ad42c8169b1600433e588c6529b96ea171405 (diff)
downloadaur-7b57896a3afbc2804bd136d890f6c22af3ca03c7.tar.gz
add submodules properly
Signed-off-by: Severin Kaderli <severin@kaderli.dev>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD66
1 files changed, 65 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 142b08ed5d4f..74ba44ed79c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,9 +23,69 @@ provides=('vita3k')
conflicts=('vita3k')
source=(
"${pkgname}::git+https://github.com/vita3k/vita3k.git"
+ "${pkgname}-better-enums::git+https://github.com/aantron/better-enums.git"
+ "${pkgname}-boost::git+https://github.com/Vita3K/ext-boost.git"
+ "${pkgname}-capstone::git+https://github.com/aquynh/capstone.git"
+ "${pkgname}-crypto-algorithms::git+https://github.com/KorewaWatchful/crypto-algorithms.git"
+ "${pkgname}-dirent::git+https://github.com/tronkko/dirent.git"
+ "${pkgname}-dlmalloc::git+https://github.com/Vita3K/dlmalloc.git"
+ "${pkgname}-elfio::git+https://github.com/serge1/ELFIO.git"
+ "${pkgname}-ffmpeg::git+https://github.com/Vita3K/ffmpeg-core.git"
+ "${pkgname}-glslang::git+https://github.com/KhronosGroup/glslang.git"
+ "${pkgname}-googletest::git+https://github.com/google/googletest.git"
+ "${pkgname}-imgui::git+https://github.com/ocornut/imgui.git"
+ "${pkgname}-imgui_club::git+https://github.com/ocornut/imgui_club.git"
+ "${pkgname}-libfat16::git+https://github.com/Vita3K/libfat16.git"
+ "${pkgname}-microprofile::git+https://github.com/jonasmr/microprofile.git"
+ "${pkgname}-nativefiledialog-cmake::git+https://github.com/Vita3K/nativefiledialog-cmake.git"
+ "${pkgname}-printf::git+https://github.com/Vita3K/printf.git"
+ "${pkgname}-pugixml::git+https://github.com/zeux/pugixml.git"
+ "${pkgname}-sdl::git+https://github.com/Vita3K/sdl.git"
+ "${pkgname}-sdl2-cmake-scripts::git+https://github.com/tcbrindle/sdl2-cmake-scripts.git"
+ "${pkgname}-spdlog::git+https://github.com/gabime/spdlog.git"
+ "${pkgname}-SPIRV-Cross::git+https://github.com/KhronosGroup/SPIRV-Cross.git"
+ "${pkgname}-stb::git+https://github.com/nothings/stb.git"
+ "${pkgname}-unicorn::git+https://github.com/Vita3K/unicorn.git"
+ "${pkgname}-vita-toolchain::git+https://github.com/vitasdk/vita-toolchain.git"
+ "${pkgname}-VulkanMemoryAllocator::git+https://github.com/GPUOpen-LibrariesAndSDKs/VulkanMemoryAllocator.git"
+ "${pkgname}-yaml-cpp::git+https://github.com/jbeder/yaml-cpp.git"
+ "${pkgname}-psvpfstools::git+https://github.com/Vita3K/psvpfstools.git"
+ "${pkgname}-xxHash::git+https://github.com/Cyan4973/xxHash.git"
+ "${pkgname}-dynarmic::git+https://github.com/Vita3K/dynarmic.git"
+ "${pkgname}-fmt::git+https://github.com/fmtlib/fmt.git"
)
md5sums=(
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
)
pkgver() {
@@ -35,7 +95,11 @@ pkgver() {
prepare() {
cd "${pkgname}"
- git submodule update --init --recursive
+
+ git submodule init
+ # Use the submodules declared in the sources array
+ git submodule foreach 'git config submodule.${name}.url ${srcdir}/${pkgname}-$(cut -d "/" -f 2 <<< "${name}")'
+ git submodule update --recursive --init
}
build() {