summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEXtremeExploit2022-06-15 22:14:17 -0300
committerEXtremeExploit2022-06-15 22:14:17 -0300
commitb4f18294206da53cee1ae26d544c24ac9f212060 (patch)
tree73cc3d1b51c930b5795b6415033ed9a17f9e9da5 /PKGBUILD
parentc4323f9b47532a850c34ba0597b430ced17c009d (diff)
downloadaur-b4f18294206da53cee1ae26d544c24ac9f212060.tar.gz
Turn vulkan on and fix capitalization
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 123a22553698..df94bf9d8af4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: aimileus < $(echo YWltaWxpdXNAcHJvdG9ubWFpbC5jb20K | base64 -d)
_pkgname="vita3k"
pkgname="${_pkgname}-git"
-pkgver=r2665.5a95ee51
+pkgver=r2676.51175bd8
pkgrel=1
pkgdesc="Experimental PlayStation Vita emulator"
arch=('x86_64')
@@ -25,7 +25,7 @@ depends=(
provides=('vita3k')
conflicts=('vita3k')
source=(
- "${pkgname}::git+https://github.com/vita3k/vita3k.git"
+ "${pkgname}::git+https://github.com/Vita3K/Vita3K.git"
"vita3k.desktop"
)
b2sums=(
@@ -41,6 +41,7 @@ pkgver() {
prepare() {
cd "${srcdir}/${pkgname}"
+
git submodule update --init --recursive
}
@@ -50,7 +51,7 @@ build() {
export CC="/usr/bin/clang"
export CXX="/usr/bin/clang++"
- cmake -S . -B build-linux -G Ninja -DCMAKE_TOOLCHAIN_FILE=./cmake/toolchain/linux-x64.cmake -DCMAKE_BUILD_TYPE=Release -DUSE_VULKAN=OFF -DUSE_DISCORD_RICH_PRESENCE=OFF
+ cmake -S . -B build-linux -G Ninja -DCMAKE_TOOLCHAIN_FILE=./cmake/toolchain/linux-x64.cmake -DCMAKE_BUILD_TYPE=Release -DUSE_VULKAN=ON -DUSE_DISCORD_RICH_PRESENCE=OFF
cmake --build build-linux
}