summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSolomon Choina2015-06-10 18:31:25 -0400
committerSolomon Choina2015-06-10 18:31:25 -0400
commitc64851b37fa1e9a4e96da2bf2825213684d1f9ca (patch)
tree6e601f722574f062358d1d3a86423d0734d2f1a3 /PKGBUILD
downloadaur-c64851b37fa1e9a4e96da2bf2825213684d1f9ca.tar.gz
first import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD107
1 files changed, 107 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb31777bbabc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,107 @@
+# $Id$
+# Maintainer: Sebastian Weiland <sebastianweiland97@gmail.com>
+# Original package: Xavion <Xavion (dot) 0 (at) Gmail (dot) com>
+
+_appname_=vlc
+pkgname=${_appname_}-nightly
+pkgver=3.0.0
+_snapshot_=20150511-0533
+pkgrel=4
+pkgdesc="A multi-platform MPEG, VCD/DVD, and DivX player - nightly GIT snapshot"
+arch=("i686" "x86_64")
+url="http://www.videolan.org/vlc/"
+license=("LGPL2.1" "GPL2")
+depends=("a52dec" "libdvbpsi" "libxpm" "libdca" "qt4" "libproxy"
+ "sdl_image" "libdvdnav" "libtiger" "lua" "libmatroska"
+ "zvbi" "taglib" "libmpcdec" "ffmpeg" "faad2" "libupnp"
+ "libshout" "libmad" "directfb" "libmpeg2" "libmodplug" "libass"
+ "xcb-util-keysyms")
+makedepends=("live-media" "libnotify" "libbluray" "flac" "kdelibs"
+ "fluidsynth" "libdc1394" "libavc1394" "lirc-utils"
+ "libcaca" "librsvg" "portaudio" "libgme" "xosd"
+ "projectm" "twolame" "aalib" "libmtp" "libdvdcss"
+ "gnome-vfs" "libgoom2" "libtar" "vcdimager" "opus" "libssh2"
+ "mesa")
+optdepends=("avahi: for service discovery using bonjour protocol"
+ "libnotify: for notification plugin"
+ "ncurses: for ncurses interface support"
+ "libdvdcss: for decoding encrypted DVDs"
+ "lirc-utils: for lirc plugin"
+ "libavc1394: for devices using the 1394ta AV/C"
+ "libdc1394: for IEEE 1394 plugin"
+ "kdelibs: KDE Solid hardware integration"
+ "libva-vdpau-driver: vdpau back-end for nvidia"
+ "libva-intel-driver: back-end for intel cards"
+ "libbluray: for Blu-Ray support"
+ "flac: for Free Lossless Audio Codec plugin"
+ "portaudio: for portaudio support"
+ "twolame: for TwoLAME mpeg2 encoder plugin"
+ "projectm: for ProjectM visualisation plugin"
+ "libcaca: for colored ASCII art video output"
+ "libgme: for libgme plugin"
+ "librsvg: for SVG plugin"
+ "gnome-vfs: for GNOME Virtual File System support"
+ "libgoom2: for libgoom plugin"
+ "vcdimager: navigate VCD with libvcdinfo"
+ "xosd: for xosd support"
+ "aalib: for ASCII art plugin"
+ "libmtp: for MTP devices support"
+ "fluidsynth: for synthesizer MIDI FluidSynth"
+ "smbclient: for SMB access plugin"
+ "libcdio: for audio CD playback support"
+ "ttf-freefont: for subtitle font "
+ "ttf-dejavu: for subtitle font"
+ "opus: for opus support"
+ "libssh2: for sftp support")
+conflicts=("${_appname_}-plugin" "${_appname_}")
+provides=("${_appname_}")
+replaces=("${_appname_}-plugin")
+#backup=("usr/share/${_appname_}/lua/http/.hosts"
+# "usr/share/${_appname_}/lua/http/dialogs/.hosts")
+options=("!libtool" "!emptydirs")
+install="${pkgname}.install"
+source=("http://nightlies.videolan.org/build/source/vlc-${pkgver}-${_snapshot_}.tar.xz")
+
+build() {
+ cd "${_appname_}-3.0.0-git"
+
+ ./bootstrap
+
+ # Patch
+ sed -i -e 's:truetype/freefont:TTF:g' modules/text_renderer/freetype.c
+ sed -i -e 's:truetype/ttf-dejavu:TTF:g' modules/visualization/projectm.cpp
+
+ # Config
+ [ ${CARCH} = 'x86_64' ] && CXXFLAGS="$CXXFLAGS -fPIC"
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --disable-rpath \
+ --enable-faad \
+ --enable-nls \
+ --enable-lirc \
+ --enable-pvr \
+ --enable-ncurses \
+ --enable-realrtsp \
+ --enable-xosd \
+ --enable-aa \
+ --enable-vcdx \
+ --enable-upnp \
+ --enable-opus \
+ --enable-sftp
+
+ make -i
+}
+
+package() {
+ cd "${_appname_}-3.0.0-git"
+
+ make -i DESTDIR="${pkgdir}" install
+
+ for res in 16 32 48 128; do
+ install -D -m644 "${srcdir}/${_appname_}-3.0.0-git/share/icons/${res}x${res}/${_appname_}.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${res}x${res}/apps/${_appname_}.png"
+ done
+}
+
+sha1sums=('fad00a10e8c78ea0b1a5b619278d8c024de90eef')