summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBooloki2016-02-18 19:15:08 +0100
committerBooloki2016-02-18 19:15:08 +0100
commitbf236ed8d6b56d02b775ad6c5b4ca591eb3b026f (patch)
tree365201856fd7f08070672ed3563aabf49992fe0e /PKGBUILD
downloadaur-bf236ed8d6b56d02b775ad6c5b4ca591eb3b026f.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD106
1 files changed, 106 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4fc30b57b68c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,106 @@
+# $Id$
+# Maintainer : Nicolas Perrin <booloki@lokizone.net>
+# Contributor: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Sarah Hay <sarahhay@mb.sympatico.ca>
+# Contributor: Martin Sandsmark <martin.sandsmark@kde.org>
+
+_pkgbase=vlc
+pkgname=vlc-nox
+pkgver=2.2.2
+pkgrel=1
+pkgdesc="A multi-platform MPEG, VCD/DVD, and DivX player (without X support)"
+arch=('i686' 'x86_64')
+url="http://www.videolan.org/vlc/"
+license=('LGPL2.1' 'GPL2')
+depends=('a52dec' 'libdvbpsi' 'libxpm' 'libdca' 'libproxy'
+ 'sdl_image' 'libdvdnav' 'libtiger' 'lua' 'libmatroska'
+ 'zvbi' 'taglib' 'libmpcdec' 'ffmpeg' 'faad2' 'libupnp'
+ 'libshout' 'libmad' 'libmpeg2' 'xcb-util-keysyms' 'libtar'
+ 'libxinerama')
+makedepends=('live-media' 'libnotify' 'libbluray' 'flac'
+ 'libdc1394' 'libavc1394' 'lirc' 'libcaca'
+ 'librsvg' 'portaudio' 'libgme' 'xosd' 'projectm'
+ 'twolame' 'aalib' 'libmtp' 'libdvdcss'
+ 'libgoom2' 'vcdimager' 'opus' 'libssh2' 'mesa')
+optdepends=('avahi: for service discovery using bonjour protocol'
+ 'ncurses: for ncurses interface support'
+ 'libdvdcss: for decoding encrypted DVDs'
+ 'lirc: for lirc plugin'
+ 'libavc1394: for devices using the 1394ta AV/C'
+ 'libdc1394: for IEEE 1394 plugin'
+ 'libva-vdpau-driver: vdpau back-end for nvidia'
+ 'libva-intel-driver: back-end for intel cards'
+ 'libbluray: for Blu-Ray support'
+ 'flac: for Free Lossless Audio Codec plugin'
+ 'portaudio: for portaudio support'
+ 'twolame: for TwoLAME mpeg2 encoder plugin'
+ 'projectm: for ProjectM visualisation plugin'
+ 'libcaca: for colored ASCII art video output'
+ 'libgme: for libgme plugin'
+ 'librsvg: for SVG plugin'
+ 'libgoom2: for libgoom plugin'
+ 'vcdimager: navigate VCD with libvcdinfo'
+ 'aalib: for ASCII art plugin'
+ 'libmtp: for MTP devices support'
+ 'smbclient: for SMB access plugin'
+ 'libcdio: for audio CD playback support'
+ 'ttf-freefont: for subtitle font '
+ 'ttf-dejavu: for subtitle font'
+ 'opus: for opus support'
+ 'libssh2: for sftp support'
+ 'lua-socket: for http interface')
+conflicts=('${_pkgbase}' 'vlc-plugin' 'vlc-git')
+replaces=('${_pkgbase}' 'vlc-plugin' 'vlc-git')
+backup=('usr/share/vlc/lua/http/.hosts'
+ 'usr/share/vlc/lua/http/dialogs/.hosts')
+options=('!emptydirs')
+install=${_pkgbase}.install
+source=("http://download.videolan.org/${_pkgbase}/${pkgver}/${_pkgbase}-${pkgver}.tar.xz"
+ "lua53_compat.patch")
+md5sums=('f98d60f0f59ef72b6e3407f2ff09bda6'
+ '96d3b346d9149ffb1b430066dfb6249a')
+
+prepare() {
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+
+ sed -i -e 's:truetype/freefont:TTF:g' modules/text_renderer/freetype.c
+ sed -i -e 's:truetype/ttf-dejavu:TTF:g' modules/visualization/projectm.cpp
+
+ patch -p1 < "${srcdir}/lua53_compat.patch"
+}
+
+build() {
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+
+ CFLAGS+=" -I/usr/include/samba-4.0" CPPFLAGS+=" -I/usr/include/samba-4.0" \
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --disable-qt \
+ --disable-skins2 \
+ --disable-rpath \
+ --enable-faad \
+ --enable-nls \
+ --enable-lirc \
+ --enable-ncurses \
+ --enable-realrtsp \
+ --enable-aa \
+ --enable-vcdx \
+ --enable-upnp \
+ --enable-opus \
+ --enable-sftp \
+ LUAC=/usr/bin/luac LUA_LIBS="`pkg-config --libs lua`" \
+ RCC=/usr/bin/rcc-qt4
+
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgbase}-${pkgver}"
+
+ make DESTDIR="${pkgdir}" install
+
+ for res in 16 32 48 128; do
+ install -D -m644 "${srcdir}/vlc-${pkgver}/share/icons/${res}x${res}/vlc.png" \
+ "${pkgdir}/usr/share/icons/hicolor/${res}x${res}/apps/vlc.png"
+ done
+}