summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2020-04-11 17:15:28 +0000
committerDaniel Bermond2020-04-11 17:15:28 +0000
commit200975a10e4cc37697802ef4110053e2708bbec1 (patch)
tree0f471db6a225845cc09f03a2f2125db2cf345377 /PKGBUILD
parent1422f065dfd34067b7d10d20046eec52ccd6cbbe (diff)
downloadaur-200975a10e4cc37697802ef4110053e2708bbec1.tar.gz
Fix build by matching latest upstream changes
The vmaf binary executables has changed. References ---------- https://github.com/Netflix/vmaf/commit/10af8f245788a97c868f7ee6c52b2d838797cd41 https://github.com/Netflix/vmaf/commit/23aa467a619610e9b38f37b1ac42f797a6ee61fc
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 3 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 88cfe5b4e618..2a15d3231548 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=vmaf-git
-pkgver=1.5.1.r0.g35c6044
+pkgver=1.5.1.r41.g23aa467a
pkgrel=1
pkgdesc='Perceptual video quality assessment algorithm based on multi-method fusion (git version)'
arch=('x86_64')
@@ -15,13 +15,8 @@ replaces=('libvmaf-git')
source=('git+https://github.com/Netflix/vmaf.git')
sha256sums=('SKIP')
-prepare() {
- mkdir -p vmaf/libvmaf/build
-}
-
pkgver() {
- cd vmaf
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
+ git -C vmaf describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
build() {
@@ -35,13 +30,6 @@ check() {
package() {
DESTDIR="$pkgdir" ninja -v -C vmaf/libvmaf/build install
-
- local _bin
- install -D -m755 vmaf/libvmaf/build/tools/vmaf -t "${pkgdir}/usr/bin"
- for _bin in moment ms_ssim psnr ssim
- do
- install -D -m755 "vmaf/libvmaf/build/tools/${_bin}" "${pkgdir}/usr/bin/vmaf-${_bin}"
- done
-
+ install -D -m755 vmaf/libvmaf/build/tools/vmaf_{feature,rc} -t "${pkgdir}/usr/bin"
install -D -m644 vmaf/LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}