summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhayao2021-07-02 16:31:43 +0900
committerhayao2021-07-02 16:31:43 +0900
commit1996789f0f90c28a3bfde7623036899fb66521ad (patch)
treecf275ccf9ab917e94562cbceaac6f1b746d60d6a /PKGBUILD
parent337d42a1e58f5453027abf5211dc80a776e6a4cb (diff)
downloadaur-vmware-auto-unlocker.tar.gz
[update] : Updated 1.1.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3263cf9ed327..e2f31fdbb2ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,23 @@
-# Maintainer: mrAppleXZ <mr.applexz@gmail.com>
+# Miantainer : Yamada Hayao <hayao@fascode.net>
+# Contributer: mrAppleXZ <mr.applexz@gmail.com>
pkgname=vmware-auto-unlocker
-pkgver=1.1
+pkgver=1.1.3
pkgrel=1
pkgdesc="Unlocker for VMWare macOS"
arch=('x86_64')
url="https://github.com/paolo-projects/auto-unlocker/"
license=('GPL3')
depends=('curl' 'libarchive')
-source=("https://github.com/paolo-projects/auto-unlocker/releases/download/v${pkgver}/autounlocker_${pkgver}.0_amd64.deb")
-sha512sums=('a42c12b63774f5b8317dd1ac350b1c1f3ae9f8b3b11e1238db41725a595a8ca29b54886dce8db98e8a4bd15798d0fec280fe44221b05430f7e733d2663c6a364')
+source=("git+https://github.com/paolo-projects/auto-unlocker.git#tag=v${pkgver}")
+sha512sums=('SKIP')
+
+build(){
+ cd "${srcdir}/auto-unlocker"
+ make
+}
package() {
- msg2 "Extracting the data.tar.xz..."
- bsdtar -xf data.tar.xz -C "$pkgdir/"
+ cd "${srcdir}/auto-unlocker"
+ make PREFIX="${pkgdir}/usr" install
}