summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJean-Marc Lenoir2019-10-05 11:23:31 +0200
committerJean-Marc Lenoir2019-10-05 11:23:31 +0200
commit71fd026910dd451a8f8a402f86cca77474928682 (patch)
tree83f8d304605117c7737d988d8b624b05f957bca8 /PKGBUILD
parent6a1c8801d17f403088bd538eed381af4afb4a640 (diff)
downloadaur-71fd026910dd451a8f8a402f86cca77474928682.tar.gz
Cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 4 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4df3a8e876dd..300b71f95530 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -41,7 +41,6 @@ provides=(
)
depends=(
dkms
- ncurses5-compat-libs
fuse2
gtkmm3
libcanberra
@@ -51,8 +50,6 @@ depends=(
# needed to use Arch GTK3 library (for theme integration)
gtk3
gcr
- # needed to replace internal libs:
- #zlib
)
optdepends=(
'linux-headers: build modules against Arch kernel'
@@ -150,7 +147,7 @@ _unlocker_ver=3.0.2
_efi_unlocker_ver=1.0.0
makedepends+=(
- python2
+ python
unzip
uefitool-git
)
@@ -164,7 +161,7 @@ source+=(
sha256sums+=(
'ed819604cb9c0f204e377f16b8678103467d2cf4a50129932e2b1a9a000ad8cf'
'29e0b0db9c0296ab81eee543803c4bd430e2c69c76e33492910e17280da1c05c'
- 'd0b16c21246468869ae26cc33d64eb2790c2e9446702a40916770c9d634ef03d'
+ '4fb4a7914aee656df170e35b3ef952aaaa2ed10161e560dfa097688861127b1d'
'392c1effcdec516000e9f8ffc97f2586524d8953d3e7d6f2c5f93f2acd809d91'
)
@@ -392,8 +389,7 @@ fi
vmware-vmblock-fuse \
vmware-vprobe \
vmware-wssc-adminTool \
- vmware-zenity \
- #vmware-unity-helper
+ vmware-zenity
do
ln -s /usr/lib/vmware/bin/appLoader "$pkgdir/usr/lib/vmware/bin/$link"
done
@@ -462,7 +458,7 @@ fi
if [ -n "$_enable_macOS_guests" ]; then
msg "Patching VMware for macOS guest support"
- python2 "$srcdir/unlocker.py" > /dev/null
+ python "$srcdir/unlocker.py" > /dev/null
for isoimage in ${_fusion_isoimages[@]}
do
@@ -491,10 +487,4 @@ fi
sed -i '/^StartupNotify=.*/a StartupWMClass=vmware' "$pkgdir/usr/share/applications/vmware-workstation.desktop"
sed -i '/^StartupNotify=.*/a StartupWMClass=vmplayer' "$pkgdir/usr/share/applications/vmware-player.desktop"
sed -i '/^StartupNotify=.*/a StartupWMClass=vmware-netcfg' "$pkgdir/usr/share/applications/vmware-netcfg.desktop"
-
- # to solve bugs with incompatibles library versions:
- #ln -sf /usr/lib/libz.so.1 "$pkgdir/usr/lib/vmware/lib/libz.so.1/"
-
- # Preview license
- #install -Dm 644 vmware-workstation/etc/vmware/license-ws-150-e1-201804 "$pkgdir/etc/vmware/license-ws-150-e1-201804"
}