summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRadek Podgorny2017-05-17 02:08:32 +0200
committerRadek Podgorny2017-05-17 02:08:32 +0200
commit873898f0215b0a36573952603471b06aee52c270 (patch)
treeaf4d1c8e4182604126c45f2a4384c516407ee5a8 /PKGBUILD
downloadaur-873898f0215b0a36573952603471b06aee52c270.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f9e3edc96918
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Radek Podgorny <radek@podgorny.cz
+
+pkgname=vncsnapshot-git
+pkgver=r3.2680fcc
+pkgrel=1
+pkgdesc='VNC snapshots'
+arch=('i686' 'x86_64')
+url='https://github.com/rpodgorny/VNCsnapshot'
+license=('unknown')
+provides=('vncsnapshot')
+conflicts=('vncsnapshot')
+source=(${pkgname%-git}::git+https://github.com/rpodgorny/VNCsnapshot)
+sha256sums=('SKIP')
+#options=('!makeflags')
+
+pkgver() {
+ cd ${pkgname%-git}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${pkgname%-git}
+ make
+}
+
+package() {
+ cd ${pkgname%-git}
+ install -d $pkgdir/usr/bin
+ cp vncsnapshot $pkgdir/usr/bin/
+}