summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2021-07-12 20:28:54 +0200
committerFabioLolix2021-07-12 20:28:54 +0200
commit18ce55ab8a25b0140d6c648f65c4ab3fa4b2adac (patch)
tree119f0d28fdbf4982351ed72bec96f2d8b6ec089e /PKGBUILD
parent4c4fe0d6b73d2c6974f720268efeea1ee893592f (diff)
downloadaur-18ce55ab8a25b0140d6c648f65c4ab3fa4b2adac.tar.gz
v3.4.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 23 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a81784af4041..6dc74956d6d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,39 +2,49 @@
# Contributor: erk <v at erk dot io>
pkgname=vnote
-pkgver=2.10
-pkgrel=2
+pkgver=3.4.0
+pkgrel=1
pkgdesc="A Vim-inspired note-taking application, especially for Markdown."
arch=(x86_64 i686 arm armv6h armv7h aarch64)
url="https://vnotex.github.io/vnote/en_us/"
license=(MIT)
depends=(qt5-webengine qt5-svg)
makedepends=(git)
-source=("git+https://github.com/tamlok/vnote.git#tag=v${pkgver}"
- "git+https://github.com/chjj/marked.git"
- "git+https://github.com/tamlok/hoedown.git")
+source=("git+https://github.com/vnotex/vnote.git#tag=v${pkgver}"
+ "vnotex-vtextedit::git+https://github.com/vnotex/vtextedit"
+ "vnotex-syntax-highlighting::git+https://github.com/vnotex/syntax-highlighting"
+ "vnotex-hunspell::git+https://github.com/vnotex/hunspell"
+ "vnotex-sonnet::git+https://github.com/vnotex/sonnet")
sha256sums=('SKIP'
'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
prepare() {
- cd "$pkgname"
+ cd "${pkgname}"
+
+ install -d build
+
git submodule init
- git config 'submodule.src/utils/marked.url' "${srcdir}/marked"
- git config 'submodule.hoedown.url' "${srcdir}/hoedown"
+ git config 'submodule.libs/vtextedit.url' "${srcdir}/vnotex-vtextedit"
git submodule update
- install -d build
+ cd "libs/vtextedit"
+ git submodule init
+ git config 'submodule.src/libs/syntax-highlighting.url' "${srcdir}/vnotex-syntax-highlighting"
+ git config 'submodule.src/libs/hunspell.url' "${srcdir}/vnotex-hunspell"
+ git config 'submodule.src/libs/sonnet.url' "${srcdir}/vnotex-sonnet"
+ git submodule update
}
build() {
- cd "$pkgname/build"
- qmake ../VNote.pro
+ cd "${pkgname}/build"
+ qmake-qt5 ../vnote.pro
make
}
package() {
- cd "$pkgname/build"
+ cd "${pkgname}/build"
make INSTALL_ROOT="$pkgdir" install
- install -Dm644 "$srcdir/$pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}