summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbuj2025-03-18 22:05:25 +0700
committerbuj2025-03-18 22:05:25 +0700
commitd8c478d4472da9cd6465b95c576fa99992d0c9e6 (patch)
treefa77fdbdb1292c23d813a7fb4bfa5de3d5488cde /PKGBUILD
parent9cd6ca19a44605440f998ed8464cdb5c2b002000 (diff)
downloadaur-d8c478d4472da9cd6465b95c576fa99992d0c9e6.tar.gz
fix: updated dependecies & version is no longer huge
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1f481b210c63..3021cabba822 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
# Maintainer: buj <buj351@outlook.com>
pkgname=voidsprite-git
-pkgver=alpha19.02.2025.r4.g8372089
-pkgrel=2
-pkgdesc='Free pixelart editor made in SDL2 C++'
+pkgver=2025.03.18
+pkgrel=1
+pkgdesc='Free pixelart editor made in SDL3 C++'
url='https://github.com/counter185/voidsprite'
source=('voidsprite::git+https://github.com/counter185/voidsprite.git')
arch=('i686' 'x86_64')
conflicts=('voidsprite')
provides=('voidsprite')
sha256sums=(SKIP)
-depends=(sdl2 sdl2_image sdl2_ttf libpng pugixml xdg-utils libjxl brotli)
+depends=(sdl3 sdl3_image sdl3_ttf libpng pugixml xdg-utils libjxl brotli)
makedepends=(git meson gcc ninja python)
license=(GPL-2.0-only)
pkgver() {
- cd "${srcdir}/voidsprite"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ # voidsprite verisons are dmy dates, but we switch the order so pacman doesn't complain
+ cd "$srcdir/voidsprite"
+ git show -1 --no-patch --format=%ci | cut -f1 -d\ | tr - .
}
build() {