summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorheinrich59912019-03-30 05:34:32 +0100
committerheinrich59912019-03-30 05:34:32 +0100
commitdc33897a6e3a3cbaa600ae97e7c934ac0d57c704 (patch)
tree4d4bca8779935d2983f6f6e9760d4ff5d9cb1dfc /PKGBUILD
downloadaur-dc33897a6e3a3cbaa600ae97e7c934ac0d57c704.tar.gz
volt 0.80, initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43da988008da
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: heinrich5991 <heinrich5991@gmail.com>
+pkgname=volt
+pkgver=0.80
+pkgrel=1
+pkgdesc="Fast native desktop client Slack, Skype, Twitter, Telegram, and more"
+arch=('x86_64')
+url="https://volt-app.com/"
+license=('unknown')
+depends=(
+ 'glfw'
+ 'libcurl-compat'
+)
+options=('!strip')
+source=("https://github.com/voltapp/volt/releases/download/${pkgver}/volt_linux.zip"
+ "volt_wrapper")
+sha256sums=('c3c6e933bb680feb6c55a304fd08a61d778f07625793a81bb33998b782aa6378'
+ 'SKIP')
+
+package() {
+ install -Dm755 volt_wrapper "${pkgdir}"/usr/bin/volt
+ install -Dm755 volt "${pkgdir}"/usr/lib/volt/volt
+ install -Dm644 RobotoMono-Regular.ttf "${pkgdir}"/usr/share/volt/RobotoMono-Regular.ttf
+}