summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Avance2024-03-24 18:35:43 -0500
committerAlex Avance2024-03-24 18:36:23 -0500
commit8411a50e380f5b3ae14c937115ff5983d2ecefbd (patch)
tree3bbdc30a45f0b9d577be036005c0613b76ad2e79 /PKGBUILD
downloadaur-8411a50e380f5b3ae14c937115ff5983d2ecefbd.tar.gz
feat: initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6136b0fd78a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Alex Avance <aravance(at)gmail(dot)com>
+
+_pkgname=volume-sync
+pkgname=$_pkgname-git
+pkgver=7.3d26107
+pkgrel=1
+pkgdesc="A utility for keeping volume in sync across multiple pulse volume sinks"
+url="https://github.com/aravance/volume-sync"
+depends=('libpulse')
+makedepends=('cargo')
+arch=('x86_64')
+source=("volume-sync::git+https://github.com/aravance/volume-sync.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ cargo build --release --locked
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm0755 -t "$pkgdir/usr/bin" "target/release/$_pkgname"
+}