summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorValentin Hăloiu2019-09-15 19:31:41 +0200
committerValentin Hăloiu2019-09-15 19:31:41 +0200
commit71861c438c0a4209c729fb5c2afdb81346ec1862 (patch)
tree15496da0343f14ce334c299f43a551ff0e8cbe6f /PKGBUILD
parent156b07e6f7df6afad8bd6515a833c12d2253f0e0 (diff)
downloadaur-volumectl.tar.gz
Release v0.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4867e5cf5734..227dce7af3a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,26 @@
# Maintainer: Valentin-Costel Haloiu <vially.ichb+aur@gmail.com>
pkgname=volumectl
-pkgver=0.0.5
+pkgver=0.1.0
pkgrel=1
pkgdesc="A command line utility to control the volume"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://github.com/vially/volumectl"
-options=('!strip')
license=(MIT)
-depends=('pulseaudio' 'notify-osd')
+depends=('pulseaudio')
makedepends=('go' 'git')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/vially/${pkgname}/archive/v${pkgver}.tar.gz")
+sha512sums=('b9d935e1da512a36716c6bcc62f5e51e9e58ee835d87733ae15c93fb2954969df04e7ede5b7994a628efb094ba2f1e19a78e91290960412099db17c707755f92')
_gourl=github.com/vially/volumectl
_gitroot="https://github.com/vially/volumectl.git"
build() {
- export GOPATH="$srcdir"
- go get -x -v ${_gourl}
+ cd $pkgname-$pkgver
+ go build .
}
package() {
- install -Dm755 "$srcdir/bin/$pkgname" "$pkgdir/usr/bin/$pkgname"
- install -Dm644 "$srcdir/src/$_gourl/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 "$srcdir/$pkgname-$pkgver/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "$srcdir/$pkgname-$pkgver/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}