summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames McMurray2020-07-19 19:54:54 +0200
committerJames McMurray2020-07-19 19:54:54 +0200
commit0feb6819564fe0e8c6772170f484e9c33f2f70ba (patch)
tree6e489b166b3ebdac035e8401ccade30f25c37a5c /PKGBUILD
downloadaur-0feb6819564fe0e8c6772170f484e9c33f2f70ba.tar.gz
First release prebuilt, TODO: arm binaries
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..98c63028587b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: James McMurray <jamesmcm03@gmail.com>
+
+pkgname=vopono
+pkgver=0.2.1
+pkgrel=1
+pkgdesc='Run applications through VPN connections in network namespaces'
+arch=('x86_64')
+url='https://github.com/jamesmcm/vopono'
+license=('GPL3')
+makedepends=('git' 'rust')
+depends=('nftables' 'iptables' 'procps-ng' 'coreutils' 'findutils')
+optdepends=('openvpn: for OpenVPN connections' 'wireguard-tools: for Wireguard connections')
+source=("${pkgname}::${url}/releases/download/${pkgver}/${pkgname}_${pkgver}_linux_x86-64_musl")
+noextract=("${pkgname}")
+sha256sums=('cd2e8e8fa53802f3a419b12c8121384604c616c40b81c06a97b72e3c35696ae1')
+provides=('vopono')
+conflicts=('vopono')
+
+package() {
+ install -Dm755 ${pkgname} "${pkgdir}/usr/bin/${pkgname}"
+}