summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBjoern Franke2023-11-23 11:59:04 +0100
committerBjoern Franke2023-11-23 11:59:04 +0100
commit1c401f5e1465ea6210274e4390d53f18df14c560 (patch)
treeef8e8479027e0ae40d012ac6aa56462eef5692ea /PKGBUILD
parentfd216bba75d57e53c0342640e5e4f94d06af0693 (diff)
downloadaur-1c401f5e1465ea6210274e4390d53f18df14c560.tar.gz
use PEP517 install, thanks to xiota
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 91dde4d12bd2..fcd1f20bc6b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
# Maintainer: Bjoern Franke <bjo+aur@schafweide.org>
pkgname=vorta
-pkgver=0.8.12
-pkgrel=1
+pkgver=v0.8.12
+pkgrel=2
pkgdesc="A GUI for BorgBackup"
arch=('any')
url="https://github.com/borgbase/vorta"
license=('GPL')
depends=('borg' 'python-appdirs' 'python-pyqt5' 'python-peewee' 'python-dateutil' 'python-secretstorage' 'python-psutil' 'python-llfuse' 'python-setuptools')
-makedepends=('qt5-tools' 'python-pip')
+makedepends=('qt5-tools'
+ 'python-build'
+ 'python-installer'
+ 'python-setuptools'
+ 'python-wheel')
options=(!emptydirs)
source=("$pkgname-$pkgver.tar.gz::https://github.com/borgbase/$pkgname/archive/v$pkgver.tar.gz")
sha256sums=('697a1d6f6f93b1b2447c7f19cf250d24d72e2f784e62c54287d9ee39cac59f38')
build() {
-
cd "$pkgname-$pkgver"
make translations-to-qm
- python setup.py build
+ python -m build --no-isolation --wheel --skip-dependency-check
}
-
package() {
cd "$pkgname-$pkgver"
- export PYTHONHASHSEED=0
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="${pkgdir:?}" dist/*.whl
install -Dm644 package/icon-symbolic.svg \
"$pkgdir/usr/share/icons/hicolor/symbolic/apps/com.borgbase.Vorta-symbolic.svg"