summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHector Mtz-Seara2016-01-18 17:11:42 +0100
committerHector Mtz-Seara2016-01-18 17:11:42 +0100
commitb2179545b84d74dd41a845c31d9ebae960a63af2 (patch)
tree4bf170caed947375171c660dc930bdda36c7c250 /PKGBUILD
parent447fd7070d2b5f750627087841d5b64bae332078 (diff)
downloadaur-b2179545b84d74dd41a845c31d9ebae960a63af2.tar.gz
Updated to votca-csg-1.3-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eafba3a99a3b..ac788dcd32c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,21 @@
# Maintainer: Hector Martinez-Seara Monne <hseara ##[at]## gmail?com>
pkgname=(votca-csg)
-pkgver=1.2.4
+pkgver=1.3
pkgrel=1
pkgdesc="Versatile Object-oriented Toolkit for Coarse-graining Applications (VOTCA) is a package intended to reduce the amount of routine work when doing systematic coarse-graining of various systems."
url="http://www.votca.org/"
license=("Apache")
arch=(i686 x86_64)
-depends=('python2' 'votca-tools' 'gromacs-5.0-complete')
+depends=('python2' 'votca-tools')
+#depends=('python2' 'votca-tools' 'gromacs-5.0-complete')
optdepends=('python2-espressopp')
makedepends=('cmake' 'doxygen')
source=(https://github.com/votca/csg/archive/v${pkgver}.tar.gz)
-sha1sums=('0ff663e19892579bc286ae01375b864fe8d2e5e8')
+sha1sums=('4b7ec10f4b59852c28f6b3c203412a4a1d178188')
build() {
-# msg2 "Fixing python2 invokation"
-# cd ${srcdir}/${pkgname}-${pkgver}/share/scripts/inverse
-# sed -i 1s/python2*/python2/ *.py
- source /usr/local/gromacs/gromacs-5.0.7/bin/GMXRC
+ source /etc/profile.d/GMXRC.bash
msg2 "Building votca-csg"
#Real Configuration
mkdir -p ${srcdir}/build
@@ -26,13 +24,14 @@ build() {
cmake ../csg-${pkgver} \
-DCMAKE_INSTALL_PREFIX=/usr \
-DWITH_RC_FILES=OFF \
- -DEXTERNAL_BOOST=ON \
- -DWITH_GMX_DEVEL=ON
+ -DEXTERNAL_BOOST=ON
+
+# -DWITH_GMX_DEVEL=ON
make
}
package() {
- source /usr/local/gromacs/gromacs-5.0.7/bin/GMXRC
+ source /etc/profile.d/GMXRC.bash
msg2 "Making executables"
cd ${srcdir}/build
make DESTDIR=${pkgdir} install