summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGabriel-Andrew Pollo Guilbert2015-08-08 02:16:33 -0400
committerGabriel-Andrew Pollo Guilbert2015-08-08 02:16:33 -0400
commit6dc47dffcb45a20f06c3d90ac0fca2fa98f28b94 (patch)
tree14d7aec518111577bebcd7a151d13693abb1ba0e /PKGBUILD
downloadaur-6dc47dffcb45a20f06c3d90ac0fca2fa98f28b94.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e2eac1fc8598
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: TheNiceGuy <gabrielpolloguilbert@gmail.com>
+
+pkgname=vpaint
+pkgver=1.5
+pkgrel=1
+pkgdesc='VPaint is an experimental vector graphics editor based on the Vector Animation Complex technology.'
+arch=('i686' 'x86_64')
+license=('MIT')
+depends=('qt4' 'glu')
+makedepends=('gcc' 'make' 'qtchooser')
+url='http://www.vpaint.org'
+conflicts=()
+provides=()
+source=("vpaint::https://github.com/dalboris/vpaint/archive/v$pkgver.tar.gz")
+md5sums=('SKIP')
+options=()
+
+build() {
+ mkdir -p "$srcdir/$pkgname-$pkgver/build"
+ cd "$srcdir/$pkgname-$pkgver/build"
+
+ qmake ../src/VPaint.pro -r -spec linux-g++
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+
+ install -Dm755 "$srcdir/$pkgname-$pkgver/build/VPaint" "$pkgdir/usr/bin/vpaint"
+}