diff options
author | Gabriel-Andrew Pollo Guilbert | 2016-02-15 15:25:56 -0500 |
---|---|---|
committer | Gabriel-Andrew Pollo Guilbert | 2016-02-15 15:25:56 -0500 |
commit | 581e8339d0838c3d648de2580f1d185bbdf738cd (patch) | |
tree | 34493ccb3eb9e97314d505b27522b8cfb3812cb9 /PKGBUILD | |
parent | 560a93303376068ca4663dd50f38f0633235db9e (diff) | |
download | aur-581e8339d0838c3d648de2580f1d185bbdf738cd.tar.gz |
Sync changes with normal package
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 30 |
1 files changed, 17 insertions, 13 deletions
@@ -1,38 +1,42 @@ # Maintainer: TheNiceGuy <gabrielpolloguilbert@gmail.com> pkgname=vpaint-git -pkgver=v1.5.r40.g11d2671 +pkgver=v1.6.r0.g85d499a pkgrel=1 pkgdesc='VPaint is an experimental vector graphics editor based on the Vector Animation Complex technology. (git version)' arch=('i686' 'x86_64') license=('MIT') depends=('qt4' 'glu' 'qt5-base' 'libxkbcommon-x11') -makedepends=('gcc' 'git' 'make' 'qtchooser') +makedepends=('gcc' 'git' 'make') url='http://www.vpaint.org' conflicts=('vpaint') provides=() source=('vpaint-git::git+https://github.com/dalboris/vpaint.git') md5sums=('SKIP') -options=() + +prepare() { + gendesk -f --pkgname "$pkgname" --pkgdesc "$pkgdesc" +} pkgver() { - cd $pkgname - git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' + cd $pkgname + git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' } build() { - mkdir -p "$srcdir/$pkgname/build" - cd "$srcdir/$pkgname/build" + mkdir -p "$srcdir/$pkgname/build" + cd "$srcdir/$pkgname/build" - export CXXFLAGS="$CXXFLAGS -fPIC" - export QT_SELECT=5 + export CXXFLAGS="$CXXFLAGS -fPIC" + export QT_SELECT=5 - qmake ../src/VPaint.pro -r -spec linux-g++ - make + qmake ../src/VPaint.pro -r -spec linux-g++ + make } package() { - mkdir -p "$pkgdir/usr/bin" + mkdir -p "$pkgdir/usr/bin" - install -Dm755 "$srcdir/$pkgname/build/Gui/VPaint" "$pkgdir/usr/bin/vpaint" + install -Dm755 "$srcdir/$pkgname/build/Gui/VPaint" "$pkgdir/usr/bin/vpaint" + install -Dm644 "vpaint.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop" } |