summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJörg Thalheim2016-04-05 21:53:27 +0200
committerJörg Thalheim2016-04-05 21:53:27 +0200
commitd2a0a90f0823d2a92a78a863bb7816a3b00b7ec7 (patch)
treea9be188e03358292630be311e168a33ecf6cd179 /PKGBUILD
downloadaur-vpn-ws.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..223a11f11821
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname='vpn-ws'
+pkgver=r147.9d0e866
+pkgrel=1
+pkgdesc="A VPN server over websockets"
+url="https://github.com/unbit/vpn-ws"
+license=('GPL3')
+makedepends=('git')
+depends=('openssl')
+arch=('any')
+source=("git+https://github.com/unbit/vpn-ws.git")
+
+pkgver() {
+ cd "$srcdir/vpn-ws"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/vpn-ws"
+ export CFLAGS="-Wno-error=implicit-int $CFLAGS"
+ make vpn-ws vpn-ws-client
+ install -m 755 -d "${pkgdir}/usr/bin"
+ install -m 755 vpn-ws "${pkgdir}/usr/bin/vpn-ws"
+ install -m 755 vpn-ws-client "${pkgdir}/usr/bin/vpn-ws-client"
+}
+md5sums=('SKIP')